Foto do usuário não aparece

Foto do usuário não aparece

Mensagempor guilherme » 05 Jun 2018, 16:12

Boa tarde.
Temos o Biblivre 4.1.11 na Biblioteca do município em um computador com Windows 7 Professional. Está ocorrendo um erro com o cadastro de alguns usuários; colocamos a foto da pessoa mas não aparece a mesma depois (imagem em anexo). A imagem está no mesmo formato e tamnaho das outras. Já fiz teste de colocar a foto de uma pessoa cujo cadastro aparece a foto normalmente e mesmo com esta, não aparece a foto para o usuário com problema de foto. Isso acontece aleatóriamente.
Anexos
erro do biblivre 1.png
guilherme
 
Mensagens: 4
Data de registro: 05 Jun 2018, 15:37
 

Re: Foto do usuário não aparece

Mensagempor cleydyr » 19 Jun 2018, 11:07

Oi, guilherme! Bem-vindo ao Fórum Biblivre 4!

Pode anexar o código fonte da página para analisarmos? Você pode simplesmente salvar a página (no Chrome vá em Arquivo > Salvar página como...) no formato HTML.

Fico no aguardo.
Cleydyr de Albuquerque
Github
Timerepublik
cleydyr
Administrador
 
Mensagens: 406
Data de registro: 19 Jul 2017, 19:43
Localização: Recife
 

Re: Foto do usuário não aparece

Mensagempor guilherme » 19 Jun 2018, 15:29

Oi, Cleydyr.

Segue página salva em html e código da div.

No aguardo
Anexos
código da div.txt
(1.56 KiB) Baixado 28 vezes
página.txt
(20.2 KiB) Baixado 21 vezes
guilherme
 
Mensagens: 4
Data de registro: 05 Jun 2018, 15:37
 

Re: Foto do usuário não aparece

Mensagempor cleydyr » 20 Jun 2018, 12:23

Obrigado por fornecer os detalhes, Guilherme.

Pelo que eu estou vendo aqui, a seção da tag <img> que renderiza a foto está dentro de um bloco comentado. Não sei ainda se isso é normal e se o script faz algum truque. Tu pode anexar um backup da tua aplicação para eu dar uma sacada aqui?

Abraço.
Cleydyr de Albuquerque
Github
Timerepublik
cleydyr
Administrador
 
Mensagens: 406
Data de registro: 19 Jul 2017, 19:43
Localização: Recife
 

Re: Foto do usuário não aparece

Mensagempor guilherme » 20 Jun 2018, 14:30

Cleydyr,

Estou enviando o backup sem arquivos digitais, pois com os arquivos está dando 35 MB e não sei se aceita upload deste tamanho.

Obrigado.
Anexos
Biblivre Backup 2018-06-20 14h19m57s Exclude_digital_media.b4bz
(1.66 MiB) Baixado 21 vezes
guilherme
 
Mensagens: 4
Data de registro: 05 Jun 2018, 15:37
 

Re: Foto do usuário não aparece

Mensagempor cleydyr » 28 Set 2018, 14:48

Oi, Guilherme. Tudo bem?

Acabei não recebendo notificação desta postagem e ela se perdeu.

Eu importei o seu backup e as fotos não aparecem, mas isso é esperado se você não tiver exportado junto as mídias digitais. Você pode fazer a exportação do backup com as mídias digitais e subir para algum serviço da nuvem (o We Transfer, por exemplo) e colar o link aqui em vez de anexar o arquivo grande no próprio post.

Abraço!
Cleydyr de Albuquerque
Github
Timerepublik
cleydyr
Administrador
 
Mensagens: 406
Data de registro: 19 Jul 2017, 19:43
Localização: Recife
 

Re: Foto do usuário não aparece

Mensagempor cleydyr » 03 Out 2018, 14:19

Oi, Guilherme. Tudo bem?

Obrigado por enviar o backup. Importei o seu backup enviado por WeTransfer e ele tem várias fotos de usuários. Alguns usuários têm a foto e outros não. Está assim também no seu ambiente?

Eu vou dar uma olhada depois para descobrir por que as fotos de alguns usuários não aparecem. Minha resposta pode demorar um pouco já que estou saindo de férias. 8-)

Abraço!
Cleydyr de Albuquerque
Github
Timerepublik
cleydyr
Administrador
 
Mensagens: 406
Data de registro: 19 Jul 2017, 19:43
Localização: Recife
 

Re: Foto do usuário não aparece

Mensagempor cleydyr » 03 Out 2018, 15:06

Já vi um padrão no problema.

São usuários cujos nomes têm caracteres com acentuação (á, é, í, ó, ú, â, ê, ô, ã, õ) que estão sem foto. Deve ser algum erro de decodificação interna do Biblivre. Vou analisar o problema posteriormente.

Abraço!
Cleydyr de Albuquerque
Github
Timerepublik
cleydyr
Administrador
 
Mensagens: 406
Data de registro: 19 Jul 2017, 19:43
Localização: Recife
 

Re: Foto do usuário não aparece

Mensagempor guilherme » 19 Out 2018, 09:59

Obrigado Cleydyr.
Fico esperando.
guilherme
 
Mensagens: 4
Data de registro: 05 Jun 2018, 15:37
 

Re: Foto do usuário não aparece

Mensagempor cleydyr » 09 Dez 2018, 11:42

Oi, @guilherme. Tudo bem?

Eu acho que seu banco de dados foi simplesmente corrompido por algum erro de codificação de caracteres do navegador. Essa é minha hipótese mais forte agora. Mas, infelizmente, eu não sei como isso acontece exatamente nem posso "consertar" em definitivo se eu não tiver o passo-a-passo para reproduzir o erro do zero.

A esta altura o melhor que eu posso fazer é produzir um script com uma consulta para restaurar as fotos de usuários que não tiveram seus nomes alterados. Quem teve seu nome alterado infelizmente vai ter que ter sua foto restaurada manualmente.

Este é o SQL contido no script
Código: Selecionar tudo
with q as (
   select name, encode((CAST(single.digital_media.id as VARCHAR) || ':' || single.digital_media."name")::bytea, 'base64') as photo_id from single.digital_media
)
update single.users
set photo_id = q.photo_id
from q, single.digital_media
where q."name" = (single.users."name" || '.png')


Eu testei o script com o seu backup e parece ter funcionado, já que usuários com acentos nos nomes têm a foto exibida corretamente. Você só precisa baixar o script e executar na sua máquina (talvez com permissões de administrador). Espero que ajude.

Abraço!
Anexos
recuperar_fotos_quebradas.bat
(416 Bytes) Não foi feito download ainda
Cleydyr de Albuquerque
Github
Timerepublik
cleydyr
Administrador
 
Mensagens: 406
Data de registro: 19 Jul 2017, 19:43
Localização: Recife
 
 
Próximo

Retornar para Outros

Quem está online

Usuários vendo este fórum:: Nenhum usuário registrado online

cron